
<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="https://gmpg.org/xfn/11">
	<link rel="pingback" href="https://templatic.com/xmlrpc.php">
	<link rel="shortcut icon" href="//templatic.com/wp-content/themes/templatic/images/favicon_new.png" />
	<link href="https://fonts.googleapis.com/css?family=Roboto:300,400,500,700,900&display=swap" rel="stylesheet"> 

	<!-- Main Style -->
	<link href="https://templatic.com/wp-content/themes/templatic/style.css?ver=2.7.26" rel="stylesheet" />
	
	
	<!-- This site is optimized with the Yoast SEO Premium plugin v14.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>WordPress SEO: Everything You Need to Know About Optimizing Your WordPress Site for SEO - Templatic - Best Premium WordPress Themes for 2020</title>
	<meta name="description" content="DIY Steps and simple techniques to SEO optimize your WordPress website on your own without the help of SEO experts. Tips and tricks for SEO friendly content" />
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="WordPress SEO: Everything You Need to Know About Optimizing Your WordPress Site for SEO - Templatic - Best Premium WordPress Themes for 2020" />
	<meta property="og:description" content="DIY Steps and simple techniques to SEO optimize your WordPress website on your own without the help of SEO experts. Tips and tricks for SEO friendly content" />
	<meta property="og:url" content="https://templatic.com/newsblog/wordpress-seo/" />
	<meta property="og:site_name" content="Templatic - Best Premium WordPress Themes for 2020" />
	<meta property="article:published_time" content="2020-06-25T15:02:47+00:00" />
	<meta property="article:modified_time" content="2020-06-25T15:03:59+00:00" />
	<meta property="og:image" content="https://templatic.com/wp-themes/uploads/2020/06/seo-optimization-wp.jpg" />
	<meta name="twitter:card" content="summary" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://templatic.com/#website","url":"https://templatic.com/","name":"Templatic - Best Premium WordPress Themes for 2020","description":"Best Premium WordPress Themes for 2020 from Templatic.com","potentialAction":[{"@type":"SearchAction","target":"https://templatic.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://templatic.com/newsblog/wordpress-seo/#primaryimage","inLanguage":"en-US","url":"https://templatic.com/wp-themes/uploads/2020/06/seo-optimization-wp.jpg","width":720,"height":500},{"@type":"WebPage","@id":"https://templatic.com/newsblog/wordpress-seo/#webpage","url":"https://templatic.com/newsblog/wordpress-seo/","name":"WordPress SEO: Everything You Need to Know About Optimizing Your WordPress Site for SEO - Templatic - Best Premium WordPress Themes for 2020","isPartOf":{"@id":"https://templatic.com/#website"},"primaryImageOfPage":{"@id":"https://templatic.com/newsblog/wordpress-seo/#primaryimage"},"datePublished":"2020-06-25T15:02:47+00:00","dateModified":"2020-06-25T15:03:59+00:00","author":{"@id":"https://templatic.com/#/schema/person/09eb04399ff43e7c17f8b616bb3b949c"},"description":"DIY Steps and simple techniques to SEO optimize your WordPress website on your own without the help of SEO experts. Tips and tricks for SEO friendly content","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://templatic.com/newsblog/wordpress-seo/"]}]},{"@type":["Person"],"@id":"https://templatic.com/#/schema/person/09eb04399ff43e7c17f8b616bb3b949c","name":"Disha","image":{"@type":"ImageObject","@id":"https://templatic.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/8788222cb80826ec9663af4e216b7f4e?s=96&r=g","caption":"Disha"}}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//templatic.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://templatic.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='https://api.w.org/' href='https://templatic.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://templatic.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://templatic.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://templatic.com/?p=48216' />
<link rel="alternate" type="application/json+oembed" href="https://templatic.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftemplatic.com%2Fnewsblog%2Fwordpress-seo%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://templatic.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftemplatic.com%2Fnewsblog%2Fwordpress-seo%2F&#038;format=xml" />
    <meta property="og:title" content="WordPress SEO: Everything You Need to Know About Optimizing Your WordPress Site for SEO"/>
    <meta property="og:type" content="product"/>
    <meta property="og:url" content="https://templatic.com/newsblog/wordpress-seo/"/>
    <meta property="og:site_name" content="Templatic WordPree Themes"/>
    <meta property="og:description" content=""/>
    		<script>
			document.documentElement.className = document.documentElement.className.replace( 'no-js', 'js' );
		</script>
				<style>
			.no-js img.lazyload { display: none; }
			figure.wp-block-image img.lazyloading { min-width: 150px; }
							.lazyload, .lazyloading { opacity: 0; }
				.lazyloaded {
					opacity: 1;
					transition: opacity 400ms;
					transition-delay: 0ms;
				}
					</style>
		
<!-- Facebook Pixel Code -->
<script type='text/javascript'>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
</script>
<!-- End Facebook Pixel Code -->
<script type='text/javascript'>
  fbq('init', '350264168976843', [], {
    "agent": "wordpress-5.4.2-1.7.25"
});
</script><script type='text/javascript'>
  fbq('track', 'PageView', []);
</script>
<!-- Facebook Pixel Code -->
<noscript>
<img height="1" width="1" style="display:none" alt="fbpx"
src="https://www.facebook.com/tr?id=350264168976843&ev=PageView&noscript=1" />
</noscript>
<!-- End Facebook Pixel Code -->
		<style type="text/css" id="wp-custom-css">
			/*
You can add your own CSS here.

Click the help icon above to learn more.
*/
		</style>
		
	<!--<script type='text/javascript' src='https://templatic.com/wp-includes/js/jquery/jquery.js'></script>-->
	<script src="https://code.jquery.com/jquery-3.0.0.min.js"></script>
	<script src="https://templatic.com/wp-content/themes/templatic/js/owl.carousel.js"></script>
	
	<script>
		//function to fix height of iframe!
		var calcHeight = function() {
		var headerDimensions = jQuery('.preview__header').height();
		jQuery('.full-screen-preview__frame').height(jQuery(window).height() - headerDimensions);
		}

		jQuery(document).ready(function() {
		calcHeight();
		});

		jQuery(window).resize(function() {
		calcHeight();
		}).load(function() {
		calcHeight();
		});
	</script>


<!-- Google Tag Manager -->
<noscript><iframe 
height="0" width="0" style="display:none;visibility:hidden" data-src="//www.googletagmanager.com/ns.html?id=GTM-5Q6HG9" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5Q6HG9');</script>
<!-- End Google Tag Manager -->
<!-- Amember affiliate tracking code - added by RB -->
<script type="text/javascript" id='am-ctcs-v1'>
    (function(){
    var url=(("https:" == document.location.protocol) ?
        "https://templatic.com/members" : "https://templatic.com/members");
    var d=document, s=d.createElement('script'), src=d.getElementsByTagName('script')[0];
    var w = window; var lo = w.location; var hr=lo.href; var ho=lo.host;  var se=lo.search;
    var m = RegExp('[?&]ref=([^&]*)').exec(se);
    var k = RegExp('[?&]keyword=([^&]*)').exec(se);
    var ref = m && decodeURIComponent(m[1].replace(/\+/g, ' '));
    var keyword = k && k[1];
    s.type='text/javascript';s.async=true;
    var jssrc = url+'/aff/click-js/?r='+ref+'&s='+encodeURIComponent(document.referrer);
    if (k) jssrc = jssrc + '&keyword=' + keyword;
    s.src=jssrc;
    if(ref){src.parentNode.insertBefore(s,src); var uri = hr.toString().split(ho)[1];
    uri = uri.replace(m[0], "");
    if (k) uri = uri.replace(k[0], "");
    w.history.replaceState('Object', 'Title', uri);}})();
</script>
<!-- / Amember affiliate tracking code - added by RB -->


</head>
<body class="post-template-default single single-post postid-48216 single-format-standard">
	
	<!-- Hello bar starts -->
	<div id="hellobar" class="hellobar msg1 show">
		Use Coupon <strong>JULY4</strong> for a <strong>45%</strong> Discount!
	</div>
	

    <style>
        body .hellobar {
            /*background: #111 url(https://templatic.com/wp-content/themes/templatic/images/bfo-5.jpg) repeat 0 0 !important;*/
            background: #ff413f;
            border-bottom: 2px solid #ff413f !important;
            color: #fff;
        }
        body .hellobar a {
            color: #fff;
            text-decoration: underline;
        }
        body .hellobar a:hover {
            color: #f0f0d0;
        }
        body .hellobar span {
        	display: inline-block;
		    border: 1px solid #fff;
		    padding: 5px 10px 4px;
		    line-height: normal;
		    margin: 0 5px;
        }
		/*body .hellobar{display:none;}
		body .hellobar.show{display:block;}*/

		.logo-desktop, .logo-mobile { height: 50px; }
    </style>
	<!-- Hello bar ends -->

	<header class="header clearfix">
		<a rel="Home" title="Templatic" href="https://templatic.com/" class="logo">
	    	<img   alt="Templatic" data-src="https://templatic.com/wp-content/themes/templatic/images/templatic-svg-logo.svg" class="logo-desktop lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="logo-desktop" src="https://templatic.com/wp-content/themes/templatic/images/templatic-svg-logo.svg" alt="Templatic" /></noscript>
	    	<img   alt="Templatic" data-src="https://templatic.com/wp-content/themes/templatic/images/templatic-svg-logo-mobile.svg" class="logo-mobile lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="logo-mobile" src="https://templatic.com/wp-content/themes/templatic/images/templatic-svg-logo-mobile.svg" alt="Templatic" /></noscript>
	    </a>

	    <nav id="menu" class="navigation slicknav_menu">
	        <ul>
	            	            <li ><a href="https://templatic.com/wordpress-themes/">Themes</a></li>
	            	            <li ><a href="https://templatic.com/wordpress-plugins/">Plugins</a></li>
	            	            <li ><a href="https://templatic.com/premium-themes-club/">Club</a></li>
	            	            <li ><a href="https://templatic.com/templatic-wordpress-theme-installation-service/">Installation</a>
	            </li>
	            	            <li ><a href="https://templatic.com/blog/">Blog</a></li>
	            <li class="mob-opt"><a href="https://templatic.com/affiliates/"  rel="nofollow">Become an Affiliate</a></li>
	            <li class="mob-opt"><a href="https://templatic.com/contact/"  rel="nofollow">Contact</a></li>
	            <li class="mob-opt"><a href="https://templatic.com/members/member/"  rel="nofollow">My account</a></li>
	        </ul>
	    </nav>
	    
	    <nav class="navigation-right">
	        <ul class="navigation-right">
	            <li><a href="https://templatic.com/contact/"  rel="nofollow">Contact</a></li>
	            <li><a href="https://templatic.com/members/member/"  rel="nofollow">My account</a></li>
	        </ul>
	    </nav>
	</header>
	
			
			<script type="text/javascript">
		        jQuery(document).ready(function(){
		            jQuery('#menu').slicknav();
		        });
		        if (typeof (cart) == "undefined")
		        document.write("<scr" + "ipt src='//templatic.com/members/application/cart/views/public/js/cart.js'></scr" + "ipt>");
		        jQuery(function(){cart._countOnly(); });

		                jQuery(document).ready(function (e) {
		        jQuery('#banner_club').click(function() {
		        window.location.href = '//templatic.com/premium-themes-club/';
		        });
		        jQuery(".cart_item_lightbox_trigger").click(function (e) {
		        e.preventDefault();
		        var t = jQuery(this).attr("href");
		        if (jQuery("#cart_items_lightbox").length > 0) {
		        jQuery("#cart_items_lightbox").show()
		                cart._displaycart_checkoutOnly();
		        cart._countOnly();
		        }
		        });
		        jQuery(".cart_items_lightbox").on("click", function (e) {
		        jQuery("#cart_items_lightbox").hide()
		        })
		                jQuery("#cart_items_lightbox").on("click", function (e) {
		        var t = jQuery(this).attr("id");
		        var n = jQuery(this).find("div:first").attr("id");
		        if (e.target.id == "cart_items_lightbox") {
		        jQuery("#cart_items_lightbox").hide()
		        }
		        })

		                jQuery("#menu-secondary-items").on("click", "li:first", function (e){
		        jQuery('#choice_1_1').attr('checked', true);
		        });
		        })

		        /* to delete the services from cart when click on check box checkbox */
		        function cart_delete(prdfld, pid){
		        if (!jQuery('#' + prdfld).is(":checked")){
		        cart.cartdeleteOnly(pid);
		        jQuery('.product-' + pid).remove();
		        }
		        }
				
		</script>
		<!--<script>
msgshow();
function msgshow() {
	setInterval(function(){ 
		if (jQuery('.msg1').hasClass('show')){
			$('.msg1').removeClass('show');
			$('.msg2').addClass('show');
		}
		else{
			$('.msg2').removeClass('show');
			$('.msg1').addClass('show');
		}
	}, 30000);
}
</script>-->

	<div id="site-content" class="site-content">
		<div  class="container ">
		<section id="content" class=" post-single content">
			
<article id="post-48216" class="post-48216 post type-post status-publish format-standard hentry category-newsblog" role="article" >

    <header class="entry-header">
    <h1 class="page-title" >WordPress SEO: Everything You Need to Know About Optimizing Your WordPress Site for SEO</h1>	
       <span class="posted-on">Posted on <a href="https://templatic.com/newsblog/wordpress-seo/" rel="bookmark"><span datetime="2020-06-25T20:32:47+05:30" content="2020-06-25T20:32:47+05:30"><time class="entry-date published" datetime="2020-06-25T20:32:47+05:30">June 25, 2020</time></span></a></span><span class="byline"> by <span class="author vcard" >Disha <span >Templatic</span></span></span>         </header><!-- .entry-header -->
	  <span >
        <meta content="https://templatic.com/wp-themes/uploads/2020/06/seo-optimization-wp.jpg">
        <meta content='500'/>
        <meta content='500'/>
  </span>
    	
	<div class="entry-summary" >   
	<p><img  alt="" width="720" height="500"  data-src="https://templatic.com/wp-themes/uploads/2020/06/seo-optimization-wp.jpg" class="alignnone size-full wp-image-48241 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://templatic.com/wp-themes/uploads/2020/06/seo-optimization-wp.jpg" alt="" width="720" height="500" class="alignnone size-full wp-image-48241" /></noscript><br />
WordPress is the most popular CMS out there. No matter the type of website you’re looking to build, you likely wouldn’t find a better combination of functionality and ease of managing your website than with WordPress.</p>
<p>WordPress comes with a lot of useful features and functionalities right out of the box, including some useful SEO elements. But as SEO is a pretty vast aspect of your website or web business, there’s a lot more to it than what WordPress offers in its basic form.</p>
<p>And that’s precisely all we will be talking about in this detailed guide to WordPress SEO. You will learn everything you need to know about optimizing your WordPress website for SEO.</p>
<p>So without further ado, let’s get down to business.</p>
<ul>
<li><a href="#theme">Finding the Right WordPress Theme</a></li>
<li><a href="#host">Right hosting service</a></li>
<li><a href="#settings">Optimizing WordPress Settings for SEO</a></li>
<li><a href="#yoast">Yoast SEO – The Best WordPress SEO Plugin</a></li>
<li><a href="#tools">Other Useful SEO Tools</a></li>
<li><a href="#content">Optimizing Your Content for SEO</a></li>
<li><a href="#images">WordPress Image SEO</a></li>
</ul>
<p><span id="more-48216"></span><br />
<a name="theme"></a></p>
<h2><b>Finding the Right WordPress Theme</b></h2>
<p><span style="font-weight: 400;">Most users look at the theme of their WordPress website only as an important component of their website’s functionality. However, your </span><a href="https://templatic.com/"><span style="font-weight: 400;">WordPress theme</span></a><span style="font-weight: 400;"> also holds a lot of importance when it comes to the SEO element of your website.</span></p>
<p><span style="font-weight: 400;">Website speed is now one of the most important SEO factors in the eyes of Google, and there are not many other factors that affect the speed of your site more than your WordPress theme.</span></p>
<p><span style="font-weight: 400;">A clean, SEO-friendly code is essential for the overall on-page SEO aspect of your website. Furthermore, a </span><a href="https://templatic.com/wordpress-themes/"><span style="font-weight: 400;">clean, fast WordPress theme</span></a><span style="font-weight: 400;"> paves the way for a fast loading time for your website.</span></p>
<p><span style="font-weight: 400;">So make sure you choose a WordPress theme that’s not only appealing and functional, but also fast and SEO-friendly.</span></p>
<p><span style="font-weight: 400;">Finally, your WordPress theme must be optimized for mobile devices as well. Google is putting more and more emphasis on optimizing your website for mobile users, and a mobile-friendly version of your website is also an SEO factor.</span><br />
<a name="host"></a></p>
<h2><b>Choosing the Right Hosting Service for Your Website</b></h2>
<p><span style="font-weight: 400;">Another important factor for your WordPress website’s speed is your website’s hosting. Even the fastest of WordPress themes wouldn’t be able to help your website load faster if the quality of your hosting service is poor.</span></p>
<p><span style="font-weight: 400;">While VPS hosting is much faster than shared hosting, it’s also very expensive. It may not meet the budget of most users who are just starting out with their WordPress website and online business.</span></p>
<p><span style="font-weight: 400;">That said, even a quality shared hosting service may help you get a great loading time for your website. You just need to find the right host.</span></p>
<p><span style="font-weight: 400;">But it may not be practically possible for most users to test different hosting services themselves to find the best one. However, we at Templatic have taken care of that for our users and readers, and based on our analysis recommend Bluehost as the best shared hosting service.</span></p>
<p><span style="font-weight: 400;">It’s not only one of the cheapest options out there, but also offers a great uptime and fast loading speed. We have a detailed </span><a href="https://templatic.com/bluehost-hosting-review/"><span style="font-weight: 400;">Bluehost review</span></a><span style="font-weight: 400;"> here to help you understand what exactly Bluehost has to offer to your website in terms of speed and performance.</span></p>
<p><span style="font-weight: 400;">If you’re on a slow host currently, you can move your WordPress website to Bluehost easily using this </span><a href="https://templatic.com/wp/moving-wordpress-site/"><span style="font-weight: 400;">hosting migration guide here</span></a><span style="font-weight: 400;">.</span><br />
<a name="settings"></a></p>
<h2><b>Optimizing WordPress Settings for SEO</b></h2>
<p><span style="font-weight: 400;">Every SEO strategy needs to start with on-page SEO, which basically means making changes directly to your site and its settings, rather than any external developments, which is mostly what you would call off-page SEO or link-building.</span></p>
<p><span style="font-weight: 400;">And your WordPress settings is an important part of your site’s on-page SEO. So let us walk you through exactly what kind of changes you need to make to your WordPress website to ensure its optimized well for the search engines.</span></p>
<h3>Installing HTTPS</h3>
<p><span style="font-weight: 400;">First things first, before we get to the WordPress settings, let us quickly explain to you that you should be install </span><a href="https://neilpatel.com/blog/does-a-ssl-certificate-affect-your-seo-a-data-driven-answer/" rel="nofollow"><span style="font-weight: 400;">HTTPS</span></a><span style="font-weight: 400;">. It isn’t the most important SEO factor out there, but it does contribute to your website’s SEO in its own way.</span></p>
<p><span style="font-weight: 400;">However, something more important to consider is that it has become an important security factor as well. Browsers now show a security error to users visiting a site without HTTPS. We have put an image below to explain how it looks like.</span></p>
<p><img   alt="" width="650" height="300" data-src="https://templatic.com/wp-themes/uploads/2020/06/HTTPS.jpg" class="alignnone size-full wp-image-48218 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="alignnone size-full wp-image-48218" src="https://templatic.com/wp-themes/uploads/2020/06/HTTPS.jpg" alt="" width="650" height="300" /></noscript></p>
<p><span style="font-weight: 400;">Installing HTTPS is not difficult. If your hosting service provides a cPanel like Bluehost, you would easily be able to find it in your cPanel, typically listed as “Let’s Encrypt”.</span></p>
<p><img   alt="" width="1247" height="475" data-srcset="https://templatic.com/wp-themes/uploads/2020/06/Lets-Encrypt-HTTPS.png 1247w, https://templatic.com/wp-themes/uploads/2020/06/Lets-Encrypt-HTTPS-768x293.png 768w" sizes="(max-width: 1247px) 100vw, 1247px" data-src="https://templatic.com/wp-themes/uploads/2020/06/Lets-Encrypt-HTTPS.png" class="alignnone size-full wp-image-48219 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="alignnone size-full wp-image-48219" src="https://templatic.com/wp-themes/uploads/2020/06/Lets-Encrypt-HTTPS.png" alt="" width="1247" height="475" srcset="https://templatic.com/wp-themes/uploads/2020/06/Lets-Encrypt-HTTPS.png 1247w, https://templatic.com/wp-themes/uploads/2020/06/Lets-Encrypt-HTTPS-768x293.png 768w" sizes="(max-width: 1247px) 100vw, 1247px" /></noscript></p>
<p><span style="font-weight: 400;">To help guide you better, we have done a fresh WordPress installation on a new domain. So we will go from the default settings to help you understand exactly what changes you need to make.</span></p>
<p><span style="font-weight: 400;">Right after installing WordPress and going to your WP dashboard, you need to install your WordPress theme first. We explained how to go about choosing the </span><a href="https://templatic.com/wordpress-themes/"><span style="font-weight: 400;">right WordPress theme</span></a><span style="font-weight: 400;"> above, let us quickly you tell you how to install it on your site.</span></p>
<p><span style="font-weight: 400;">Unless you’re installing one of the themes available in the WordPress depository, you would need to upload your WordPress theme.</span></p>
<p><span style="font-weight: 400;">To do that, hover your mouse on the Appearance tab and click on Themes. Then click on the Add New button at the top, and on Upload Theme on the next page.</span></p>
<p><span style="font-weight: 400;">You need to browse the file on your computer, and then click on the Install Now button.</span></p>
<p><img   alt="" width="1590" height="496" data-srcset="https://templatic.com/wp-themes/uploads/2020/06/WordPress-Add-Theme.png 1590w, https://templatic.com/wp-themes/uploads/2020/06/WordPress-Add-Theme-768x240.png 768w, https://templatic.com/wp-themes/uploads/2020/06/WordPress-Add-Theme-1536x479.png 1536w" sizes="(max-width: 1590px) 100vw, 1590px" data-src="https://templatic.com/wp-themes/uploads/2020/06/WordPress-Add-Theme.png" class="alignnone size-full wp-image-48220 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="alignnone size-full wp-image-48220" src="https://templatic.com/wp-themes/uploads/2020/06/WordPress-Add-Theme.png" alt="" width="1590" height="496" srcset="https://templatic.com/wp-themes/uploads/2020/06/WordPress-Add-Theme.png 1590w, https://templatic.com/wp-themes/uploads/2020/06/WordPress-Add-Theme-768x240.png 768w, https://templatic.com/wp-themes/uploads/2020/06/WordPress-Add-Theme-1536x479.png 1536w" sizes="(max-width: 1590px) 100vw, 1590px" /></noscript></p>
<p><span style="font-weight: 400;">Once uploaded, you need to click on Activate. That’s it! Your WordPress website is now up and running on the theme you just installed.</span></p>
<p><span style="font-weight: 400;">Now on to the settings. Click on the Settings tab. You don’t really need to make any technical changes here, except just editing your Site Title and Tagline to whatever you want as you can see below.</span></p>
<p><span style="font-weight: 400;">However, keeping these elements relevant to your site’s topic and niche would help with SEO.</span></p>
<p><img   alt="" width="1863" height="650" data-srcset="https://templatic.com/wp-themes/uploads/2020/06/WordPress-General-Settings.jpg 1863w, https://templatic.com/wp-themes/uploads/2020/06/WordPress-General-Settings-768x268.jpg 768w, https://templatic.com/wp-themes/uploads/2020/06/WordPress-General-Settings-1536x536.jpg 1536w" sizes="(max-width: 1863px) 100vw, 1863px" data-src="https://templatic.com/wp-themes/uploads/2020/06/WordPress-General-Settings.jpg" class="alignnone size-full wp-image-48221 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="alignnone size-full wp-image-48221" src="https://templatic.com/wp-themes/uploads/2020/06/WordPress-General-Settings.jpg" alt="" width="1863" height="650" srcset="https://templatic.com/wp-themes/uploads/2020/06/WordPress-General-Settings.jpg 1863w, https://templatic.com/wp-themes/uploads/2020/06/WordPress-General-Settings-768x268.jpg 768w, https://templatic.com/wp-themes/uploads/2020/06/WordPress-General-Settings-1536x536.jpg 1536w" sizes="(max-width: 1863px) 100vw, 1863px" /></noscript></p>
<p><span style="font-weight: 400;">Then comes the Writing tab right under General. But there’s nothing really to do here except choosing whether you would want to use the old WordPress Classic Editor or the new Block Editor.</span></p>
<p><img   alt="" width="1605" height="506" data-srcset="https://templatic.com/wp-themes/uploads/2020/06/WordPress-Writing-Settings.png 1605w, https://templatic.com/wp-themes/uploads/2020/06/WordPress-Writing-Settings-768x242.png 768w, https://templatic.com/wp-themes/uploads/2020/06/WordPress-Writing-Settings-1536x484.png 1536w" sizes="(max-width: 1605px) 100vw, 1605px" data-src="https://templatic.com/wp-themes/uploads/2020/06/WordPress-Writing-Settings.png" class="alignnone size-full wp-image-48222 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="alignnone size-full wp-image-48222" src="https://templatic.com/wp-themes/uploads/2020/06/WordPress-Writing-Settings.png" alt="" width="1605" height="506" srcset="https://templatic.com/wp-themes/uploads/2020/06/WordPress-Writing-Settings.png 1605w, https://templatic.com/wp-themes/uploads/2020/06/WordPress-Writing-Settings-768x242.png 768w, https://templatic.com/wp-themes/uploads/2020/06/WordPress-Writing-Settings-1536x484.png 1536w" sizes="(max-width: 1605px) 100vw, 1605px" /></noscript></p>
<p><span style="font-weight: 400;">Next up is the Reading text. There’s an important consideration to make here, and that’s whether you want your site’s homepage to be static or dynamic.</span></p>
<p><span style="font-weight: 400;">A static homepage means that it would remain the same no matter how many posts or pages you put up on your site, unless you make any direct changes to your site’s homepage. You can choose any page or post as your homepage when choosing a static homepage here.</span></p>
<p><span style="font-weight: 400;">The other option is displaying “your latest posts”, which as you can guess means that your latest posts would appear on your homepage.</span></p>
<p><span style="font-weight: 400;">Now, there’s no best option here. For business websites, directory websites, and other websites of a similar nature where the homepage needs to show some specific content to their visitors, a static homepage would usually turn out to be a better fit.</span></p>
<p><span style="font-weight: 400;">However, for something like a blog, it makes more sense to go with the dynamic option, showing the latest posts on your homepage. This will help readers find the latest content on your blog and also be a better option SEO-wise.</span></p>
<p><span style="font-weight: 400;">As for how many posts to display when using a dynamic homepage, that’s kind of subjective but you ideally wouldn’t want to display more than 10 posts. You don’t want your homepage to look like a mess.</span></p>
<p><span style="font-weight: 400;">Similarly, most users should only choose to display a summary of their post rather than the full text, which can again make your homepage very long and lead to a poor user experience.</span></p>
<p><img   alt="" width="1592" height="820" data-srcset="https://templatic.com/wp-themes/uploads/2020/06/WordPress-Choosing-Homepage-Type.png 1592w, https://templatic.com/wp-themes/uploads/2020/06/WordPress-Choosing-Homepage-Type-768x396.png 768w, https://templatic.com/wp-themes/uploads/2020/06/WordPress-Choosing-Homepage-Type-1536x791.png 1536w" sizes="(max-width: 1592px) 100vw, 1592px" data-src="https://templatic.com/wp-themes/uploads/2020/06/WordPress-Choosing-Homepage-Type.png" class="alignnone size-full wp-image-48223 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="alignnone size-full wp-image-48223" src="https://templatic.com/wp-themes/uploads/2020/06/WordPress-Choosing-Homepage-Type.png" alt="" width="1592" height="820" srcset="https://templatic.com/wp-themes/uploads/2020/06/WordPress-Choosing-Homepage-Type.png 1592w, https://templatic.com/wp-themes/uploads/2020/06/WordPress-Choosing-Homepage-Type-768x396.png 768w, https://templatic.com/wp-themes/uploads/2020/06/WordPress-Choosing-Homepage-Type-1536x791.png 1536w" sizes="(max-width: 1592px) 100vw, 1592px" /></noscript></p>
<p><span style="font-weight: 400;">The Discussion settings are just about your personal preferences and how you would like to manage comments. There’s nothing to do with SEO here.</span></p>
<p><span style="font-weight: 400;">The Media tab is all about the image sizes, which you wouldn’t want to mess around with unless you have a good reason to do so.</span></p>
<p><span style="font-weight: 400;">Then comes Permalinks. Now here’s something very important for your SEO.</span></p>
<p><span style="font-weight: 400;">You must always choose the “Post name” option as your permalink structure. Simply put, it would help you optimize the URLs of your posts for SEO.</span></p>
<p><img   alt="" width="1598" height="755" data-srcset="https://templatic.com/wp-themes/uploads/2020/06/URL-Structure.png 1598w, https://templatic.com/wp-themes/uploads/2020/06/URL-Structure-768x363.png 768w, https://templatic.com/wp-themes/uploads/2020/06/URL-Structure-1536x726.png 1536w" sizes="(max-width: 1598px) 100vw, 1598px" data-src="https://templatic.com/wp-themes/uploads/2020/06/URL-Structure.png" class="alignnone size-full wp-image-48224 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="alignnone size-full wp-image-48224" src="https://templatic.com/wp-themes/uploads/2020/06/URL-Structure.png" alt="" width="1598" height="755" srcset="https://templatic.com/wp-themes/uploads/2020/06/URL-Structure.png 1598w, https://templatic.com/wp-themes/uploads/2020/06/URL-Structure-768x363.png 768w, https://templatic.com/wp-themes/uploads/2020/06/URL-Structure-1536x726.png 1536w" sizes="(max-width: 1598px) 100vw, 1598px" /></noscript></p>
<p><span style="font-weight: 400;">The other URL structures are not only not as SEO-friendly, but also outdated and make for very long, untidy URLs.</span></p>
<p><span style="font-weight: 400;">However, you would still want to edit the URLs of your posts before publishing them, as if you don’t, then WordPress will simply use the entire title of your post as the dynamic part of its URL. Let us explain using an example below.</span></p>
<p><img   alt="" width="1175" height="211" data-srcset="https://templatic.com/wp-themes/uploads/2020/06/WordPress-Long-URL.png 1175w, https://templatic.com/wp-themes/uploads/2020/06/WordPress-Long-URL-768x138.png 768w" sizes="(max-width: 1175px) 100vw, 1175px" data-src="https://templatic.com/wp-themes/uploads/2020/06/WordPress-Long-URL.png" class="alignnone size-full wp-image-48225 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="alignnone size-full wp-image-48225" src="https://templatic.com/wp-themes/uploads/2020/06/WordPress-Long-URL.png" alt="" width="1175" height="211" srcset="https://templatic.com/wp-themes/uploads/2020/06/WordPress-Long-URL.png 1175w, https://templatic.com/wp-themes/uploads/2020/06/WordPress-Long-URL-768x138.png 768w" sizes="(max-width: 1175px) 100vw, 1175px" /></noscript></p>
<p><span style="font-weight: 400;">You do not want such a long URL. It may also dilute the SEO advantage of your URL.</span></p>
<p><span style="font-weight: 400;">So assuming “best WordPress themes” is our main keyword and topic here, we would want to edit this URL as something like below.</span></p>
<p><img   alt="" width="1169" height="196" data-srcset="https://templatic.com/wp-themes/uploads/2020/06/WordPress-Optimized-URL.png 1169w, https://templatic.com/wp-themes/uploads/2020/06/WordPress-Optimized-URL-768x129.png 768w" sizes="(max-width: 1169px) 100vw, 1169px" data-src="https://templatic.com/wp-themes/uploads/2020/06/WordPress-Optimized-URL.png" class="alignnone size-full wp-image-48226 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="alignnone size-full wp-image-48226" src="https://templatic.com/wp-themes/uploads/2020/06/WordPress-Optimized-URL.png" alt="" width="1169" height="196" srcset="https://templatic.com/wp-themes/uploads/2020/06/WordPress-Optimized-URL.png 1169w, https://templatic.com/wp-themes/uploads/2020/06/WordPress-Optimized-URL-768x129.png 768w" sizes="(max-width: 1169px) 100vw, 1169px" /></noscript></p>
<p><span style="font-weight: 400;">This URL is not only short and precise, but also more SEO-friendly as there’s nothing but the important keyword part in the URL.</span></p>
<p><span style="font-weight: 400;">Finally, on the last Privacy tab, you just need to set up a Privacy Policy page and choose it from the tab as your official privacy policy.</span><br />
<a name="Yoast"></a></p>
<h2><b>Yoast SEO – The Best WordPress SEO Plugin</b></h2>
<p><span style="font-weight: 400;">While making changes to your WordPress settings is a good start, you can’t go far without a dedicated SEO plugin that helps you do a lot more in terms of on-page SEO optimization of your site.</span></p>
<p><span style="font-weight: 400;">And when it comes to </span><a href="https://templatic.com/wp/wordpress-seo-plugins/"><span style="font-weight: 400;">SEO plugins</span></a><span style="font-weight: 400;">, Yoast SEO sits right at the top. It’s the most popular WordPress SEO plugin, and is a comprehensive way of setting up and managing your WordPress website’s on-page SEO.</span></p>
<p><span style="font-weight: 400;">To install </span><a href="https://templatic.com/wp/yoast-seo-premium-and-free-features/"><span style="font-weight: 400;">Yoast SEO</span></a><span style="font-weight: 400;">, hover your mouse on the Plugins tab and click on Add New. Then search for “Yoast SEO” using the search bar on the top-right.</span></p>
<p><span style="font-weight: 400;">Once it appears, click on the Install Now button, and later on the Activate button.</span></p>
<p><img   alt="" width="1605" height="669" data-srcset="https://templatic.com/wp-themes/uploads/2020/06/Yoast-SEO-Install-Plugin.png 1605w, https://templatic.com/wp-themes/uploads/2020/06/Yoast-SEO-Install-Plugin-768x320.png 768w, https://templatic.com/wp-themes/uploads/2020/06/Yoast-SEO-Install-Plugin-1536x640.png 1536w" sizes="(max-width: 1605px) 100vw, 1605px" data-src="https://templatic.com/wp-themes/uploads/2020/06/Yoast-SEO-Install-Plugin.png" class="alignnone size-full wp-image-48227 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="alignnone size-full wp-image-48227" src="https://templatic.com/wp-themes/uploads/2020/06/Yoast-SEO-Install-Plugin.png" alt="" width="1605" height="669" srcset="https://templatic.com/wp-themes/uploads/2020/06/Yoast-SEO-Install-Plugin.png 1605w, https://templatic.com/wp-themes/uploads/2020/06/Yoast-SEO-Install-Plugin-768x320.png 768w, https://templatic.com/wp-themes/uploads/2020/06/Yoast-SEO-Install-Plugin-1536x640.png 1536w" sizes="(max-width: 1605px) 100vw, 1605px" /></noscript></p>
<p><span style="font-weight: 400;">Now click on the newly-appeared Yoast SEO tab on your WordPress dashboard. It would take you to the Yoast SEO dashboard under General settings, where you would be able to find and see if you have any technical issues on your site.</span></p>
<p><img   alt="" width="1602" height="763" data-srcset="https://templatic.com/wp-themes/uploads/2020/06/Yoast-SEO-General-Features.png 1602w, https://templatic.com/wp-themes/uploads/2020/06/Yoast-SEO-General-Features-768x366.png 768w, https://templatic.com/wp-themes/uploads/2020/06/Yoast-SEO-General-Features-1536x732.png 1536w" sizes="(max-width: 1602px) 100vw, 1602px" data-src="https://templatic.com/wp-themes/uploads/2020/06/Yoast-SEO-General-Features.png" class="alignnone size-full wp-image-48228 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="alignnone size-full wp-image-48228" src="https://templatic.com/wp-themes/uploads/2020/06/Yoast-SEO-General-Features.png" alt="" width="1602" height="763" srcset="https://templatic.com/wp-themes/uploads/2020/06/Yoast-SEO-General-Features.png 1602w, https://templatic.com/wp-themes/uploads/2020/06/Yoast-SEO-General-Features-768x366.png 768w, https://templatic.com/wp-themes/uploads/2020/06/Yoast-SEO-General-Features-1536x732.png 1536w" sizes="(max-width: 1602px) 100vw, 1602px" /></noscript></p>
<p><span style="font-weight: 400;">When you click on the Features tab next to the Dashboard, you can see some of the main features of Yoast SEO. It’s recommended to keep them all On unless you have some specific reasons for turning any of them off.</span></p>
<p><span style="font-weight: 400;">However, if you’re using any other dedicated plugin for XML Sitemaps, then you would want to turn off that feature here. But if you don’t have any other plugin generating an XML sitemap for your site, then let it stay on.</span></p>
<p><span style="font-weight: 400;">An XML Sitemap is basically the entire structure of your website in terms of the URLs. When you submit an XML sitemap to Google or other search engines, it helps them discover all the posts and pages on your WordPress website easily.</span></p>
<p><span style="font-weight: 400;">Next to the Features is the Webmaster tab, where you can set up your website in Google Search Console and also in other search engines like Bing.</span></p>
<p><span style="font-weight: 400;">Then click on the Search Appearance option under the Yoast SEO tab on your WP dashboard. </span></p>
<p><span style="font-weight: 400;">The General settings here are all about your personal preferences. They help you decide how your posts and pages appear in the search engines.</span></p>
<p><span style="font-weight: 400;">Something you should note here is to keep the SEO title short, and remove elements you don’t really need. A short, SEO-optimized title works well in the search engines than a long one, as there are only so many characters that can appear in the search results.</span></p>
<p><span style="font-weight: 400;">The next tab is the Content Types. The only thing that needs your attention here SEO-wise is whether to display the date in Google search preview.</span></p>
<p><span style="font-weight: 400;">Now, most sites wouldn’t really need it, but if you’re running a site where you constantly need to post fresh and updated content, then you would probably want to set it to Show. A news website, for example, would require the date to be shown in the search results.</span></p>
<p><span style="font-weight: 400;">Skip the Media tab. There’s nothing to be done there.</span></p>
<p><span style="font-weight: 400;">Now, under Taxonomies, an important consideration is whether or not to show the categories in the search results. There are kind of mixed opinions about this in the SEO community, but we think you would be better off not displaying categories in the search engines.</span></p>
<p><span style="font-weight: 400;">This is because category pages usually don’t hold much importance in the search results, and can even cause some duplication of content. Not that Google would penalize you for it, but given that there’s nothing meaningful you would get out of it, it’s probably wise to set it to No.</span></p>
<p><span style="font-weight: 400;">This is especially true for large sites – such as e-commerce sites – which may have hundreds of category pages. You would want Google to crawl your important pages, and not empty or duplicated category pages that you wouldn’t want your visitors visiting anyway.</span></p>
<p><span style="font-weight: 400;">Next up is author archives. Now again, there’s nothing set in stone about it, but we prefer not to index them in the search engines for pretty much the same reasons as the category pages.</span></p>
<p><span style="font-weight: 400;">The next tab is Breadcrumbs, something you don’t need unless you have a very large website. If you do, you will need to set it to Enabled and then do some research about setting it up properly.</span></p>
<p><span style="font-weight: 400;">Leave the last RSS settings tab as is.</span></p>
<p><span style="font-weight: 400;">There are also Social settings under the Search Appearance option, but there aren’t directly related to SEO and you just need to put the URLs of your social media profiles there.</span><br />
<a name="tools"></a></p>
<h2><b>Other Useful SEO Tools</b></h2>
<p><span style="font-weight: 400;">While Yoast SEO is one of the most important WordPress plugins for building an SEO foundation for your WordPress website, there are other SEO tools that help cover different areas of SEO as well.</span></p>
<p><span style="font-weight: 400;">Let us introduce you to them below.</span></p>
<h3><a href="https://ads.google.com/intl/en_in/home/tools/keyword-planner/" rel="nofollow"><b>Google Keyword Planner</b></a></h3>
<p><span style="font-weight: 400;">Google Keyword Planner is a free tool from Google that helps you get an idea of the keyword volume for the topics you want to target.</span></p>
<p><span style="font-weight: 400;">In other words, it helps you find relevant keywords that are getting a fair number of searches from your target audience. Keyword research is one of the most important components of an SEO strategy, and Google Keyword Planner helps you do in-depth keyword research.</span></p>
<p><span style="font-weight: 400;">However, there’s a limitation with the Google Keywords Planner. It only shows you the exact keyword volume if you’re running ads on Google.</span></p>
<p><span style="font-weight: 400;">Users who aren’t running any ads only get to see a keyword range. Check out the below image to get an idea of what kind of data you would get as a free user.</span></p>
<p><img   alt="" width="922" height="200" data-srcset="https://templatic.com/wp-themes/uploads/2020/06/Google-Keyword-Planner.png 922w, https://templatic.com/wp-themes/uploads/2020/06/Google-Keyword-Planner-768x167.png 768w" sizes="(max-width: 922px) 100vw, 922px" data-src="https://templatic.com/wp-themes/uploads/2020/06/Google-Keyword-Planner.png" class="alignnone size-full wp-image-48229 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="alignnone size-full wp-image-48229" src="https://templatic.com/wp-themes/uploads/2020/06/Google-Keyword-Planner.png" alt="" width="922" height="200" srcset="https://templatic.com/wp-themes/uploads/2020/06/Google-Keyword-Planner.png 922w, https://templatic.com/wp-themes/uploads/2020/06/Google-Keyword-Planner-768x167.png 768w" sizes="(max-width: 922px) 100vw, 922px" /></noscript></p>
<p><span style="font-weight: 400;">But if you’re after a free alternative to Google Keywords Planner that shows the exact keyword data, Neil Patel’s Uber Suggest is a good tool.</span></p>
<h3><a href="https://neilpatel.com/ubersuggest/" rel="nofollow"><b>Neil Patel’s Uber Suggest</b></a></h3>
<p><span style="font-weight: 400;">This is a pretty neat keyword research tool that gives you a lot of data – including exact keyword volume numbers – without charging you anything. Here’s the kind of results you get.</span></p>
<p><img   alt="" width="1450" height="568" data-srcset="https://templatic.com/wp-themes/uploads/2020/06/Neil-Patel-Uber-Suggest.png 1450w, https://templatic.com/wp-themes/uploads/2020/06/Neil-Patel-Uber-Suggest-768x301.png 768w" sizes="(max-width: 1450px) 100vw, 1450px" data-src="https://templatic.com/wp-themes/uploads/2020/06/Neil-Patel-Uber-Suggest.png" class="alignnone size-full wp-image-48231 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="alignnone size-full wp-image-48231" src="https://templatic.com/wp-themes/uploads/2020/06/Neil-Patel-Uber-Suggest.png" alt="" width="1450" height="568" srcset="https://templatic.com/wp-themes/uploads/2020/06/Neil-Patel-Uber-Suggest.png 1450w, https://templatic.com/wp-themes/uploads/2020/06/Neil-Patel-Uber-Suggest-768x301.png 768w" sizes="(max-width: 1450px) 100vw, 1450px" /></noscript></p>
<p><span style="font-weight: 400;">So along with getting the keyword volume and some other useful metrics for the keyword you search for, it also provides keyword suggestions which may help you discover more relevant keywords to target as you can see above.</span></p>
<h3><a href="https://www.semrush.com/" rel="nofollow"><b>SEMRush</b></a></h3>
<p><span style="font-weight: 400;">When it comes to doing competitor research and finding tons of relevant, high volume keywords, there aren’t many better tools out there than SEMRush. It’s one of the most popular tools in the SEO community for doing keyword research and finding the keywords your competitors are ranking for.</span></p>
<p><span style="font-weight: 400;">SEMRush is actually a paid tool, but offers both a free trial with all the features and also a completely free, limited version of the tool.</span></p>
<p><span style="font-weight: 400;">All you need to do is put in the domain name of your own website or your competitor’s website to see the keywords that website is ranking for. It helps you find out the keywords you’re ranking for and make the required optimizations to further increase your keyword rankings, as well as find out what keywords your competitors are ranking for so that you can target their keywords as well.</span></p>
<p><img   alt="" width="1542" height="753" data-srcset="https://templatic.com/wp-themes/uploads/2020/06/SEMRush.png 1542w, https://templatic.com/wp-themes/uploads/2020/06/SEMRush-768x375.png 768w, https://templatic.com/wp-themes/uploads/2020/06/SEMRush-1536x750.png 1536w" sizes="(max-width: 1542px) 100vw, 1542px" data-src="https://templatic.com/wp-themes/uploads/2020/06/SEMRush.png" class="alignnone size-full wp-image-48232 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="alignnone size-full wp-image-48232" src="https://templatic.com/wp-themes/uploads/2020/06/SEMRush.png" alt="" width="1542" height="753" srcset="https://templatic.com/wp-themes/uploads/2020/06/SEMRush.png 1542w, https://templatic.com/wp-themes/uploads/2020/06/SEMRush-768x375.png 768w, https://templatic.com/wp-themes/uploads/2020/06/SEMRush-1536x750.png 1536w" sizes="(max-width: 1542px) 100vw, 1542px" /></noscript></p>
<p><span style="font-weight: 400;">Furthermore, it also goes a long way in helping you identify who your competitors are. There are also many other useful features like keyword competition analysis and site audit.</span></p>
<h3><a href="https://analytics.google.com" rel="nofollow"><b>Google Analytics</b></a></h3>
<p><span style="font-weight: 400;">Google Analytics helps you get a lot of details and data about your visitors and the traffic you’re getting. The insight it provides would turn out to be a great help when optimizing your website to get more traffic as well as serving your visitors better.</span></p>
<p><span style="font-weight: 400;">We already have an </span><a href="https://templatic.com/wp/google-analytics-wordpress/"><span style="font-weight: 400;">in-depth guide on Google Analytics</span></a><span style="font-weight: 400;"> so we won’t go into much more details here.</span><br />
<a name="content"></a></p>
<h2><b>Optimizing Your Content for SEO</b></h2>
<p><span style="font-weight: 400;">Nothing can help you with your SEO more than your content. No matter how important SEO factors get, content is still the king, and will continue to be the most important element determining your website’s rankings in the search engine.</span></p>
<p><span style="font-weight: 400;">It’s very important to keep SEO in mind when writing, formatting and posting your content. Let us walk you through the most important elements of SEO-optimized content.</span></p>
<h3><b><i>Targeting Keywords</i></b></h3>
<p><span style="font-weight: 400;">You need to do some keyword research that your target audience is search for, and include those keywords at the right places in your content.</span></p>
<p><span style="font-weight: 400;">Ideally, your keyword needs to appear at the following places in your content.</span></p>
<ul>
<li style="font-weight: 400;"><span style="font-weight: 400;">Title</span></li>
<li style="font-weight: 400;"><span style="font-weight: 400;">H1 (header tag)</span></li>
<li style="font-weight: 400;"><span style="font-weight: 400;">A few times in the body or other areas of your content</span></li>
</ul>
<p><span style="font-weight: 400;">Now, please note that the way you need to include these keywords have changed drastically over the last few years. Back when “SEO” was a new term, all you had to do to rank for your keywords was stuff them into your content as much as you could.</span></p>
<p><span style="font-weight: 400;">But we are well past that age. Google has become much smarter as an algorithm, and may penalize websites resorting to keyword stuffing in their content.</span></p>
<p><span style="font-weight: 400;">However, including your target keywords naturally in your content is still important, at least in some form. So for instance, if you’re trying to rank for the keyword “New York plumber”, you don’t need to put these exact words at the said areas in your content.</span></p>
<p><span style="font-weight: 400;">Writing something along the lines of “we offer all types of plumbing services in New York and surrounding areas” would suffice. Google would be able to make out you offer pluming services in New York.</span></p>
<p><span style="font-weight: 400;">But make sure you mention your keyword in some form in your content, especially in the important areas of your content we listed above.</span></p>
<p><span style="font-weight: 400;">And please ignore Yoast’s suggestions with keyword optimization. It recommends old-school practices often leading to overoptimization or keyword-stuffing that Google now frowns upon. You must remember that at the end of the day, even the Yoast SEO is a plugin, and you shouldn’t follow all its suggestions as is.</span></p>
<h3><b><i>Internal Links</i></b></h3>
<p><span style="font-weight: 400;">Internal links to other posts and pages on your website is a ranking factor, and also helps improve user experience. In addition, it lowers the bounce rate on your website and increases the time your visitors spend on your website, which are both believed to be important factors affecting the SEO of your website.</span></p>
<p><span style="font-weight: 400;">So by simply adding internal links to your content at the right places, you can cover a lot of important areas of your overall SEO process.</span></p>
<h3><b><i>Meta Description</i></b></h3>
<p><span style="font-weight: 400;">The meta description is the short description that appears in the search results with your post’s title. We have highlighted the meta description below.</span></p>
<p><img   alt="" width="957" height="204" data-srcset="https://templatic.com/wp-themes/uploads/2020/06/Meta-Description.png 957w, https://templatic.com/wp-themes/uploads/2020/06/Meta-Description-768x164.png 768w" sizes="(max-width: 957px) 100vw, 957px" data-src="https://templatic.com/wp-themes/uploads/2020/06/Meta-Description.png" class="alignnone size-full wp-image-48233 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="alignnone size-full wp-image-48233" src="https://templatic.com/wp-themes/uploads/2020/06/Meta-Description.png" alt="" width="957" height="204" srcset="https://templatic.com/wp-themes/uploads/2020/06/Meta-Description.png 957w, https://templatic.com/wp-themes/uploads/2020/06/Meta-Description-768x164.png 768w" sizes="(max-width: 957px) 100vw, 957px" /></noscript></p>
<p><span style="font-weight: 400;">Now, meta description isn’t a ranking factor in itself. However, a well-written meta description can help encourage the users performing the search to click on your search result.</span></p>
<p><span style="font-weight: 400;">This helps pave the way for a higher click-through rate, which is a ranking factor. As your click-through rate (CTR) in the search results goes up, your rankings follow suit, too.</span></p>
<p><span style="font-weight: 400;">Make sure the meta descriptions of your posts do a good job of defining what the post is about while also encouraging the users to click on your search result.</span></p>
<h3><b>WordPress Site Speed Optimization</b></h3>
<p><span style="font-weight: 400;">The speed of your website has become one of the most important ranking factors in Google. A website with a very poor loading time would struggle to rank in Google even with the best content and perfect optimization of the other areas of your website.</span></p>
<p><span style="font-weight: 400;">While a clean, <a href="https://templatic.com/wp/seo-friendly-wordpress-themes/">SEO-optimized WordPress theme</a> and a good host would go a long way in helping improve your website’s loading time, there’s more you can and need to do to make your site load even faster.</span></p>
<p><span style="font-weight: 400;">After all, a slow loading website is not only an SEO issue, but would also result in lost visitors. Research shows that the longer your website takes to load, the more the visitors who decide to leave your website even before it loads.</span></p>
<p><span style="font-weight: 400;">You must take the following steps to ensure a </span><a href="https://templatic.com/wp/speed-up-wordpress-blog/"><span style="font-weight: 400;">faster loading WordPress website</span></a><span style="font-weight: 400;">.</span></p>
<h3><b><i>Caching</i></b></h3>
<p><span style="font-weight: 400;">Caching is basically making static pages out of your WordPress website’s posts and pages. Whenever users visit your website, they are served this static version of your posts and pages, instead of fetching them from the server.</span></p>
<p><span style="font-weight: 400;">How does this help? Whenever a user makes a query, your WordPress website fetches the requested data from your server and then serves it to the user.</span></p>
<p><span style="font-weight: 400;">Imagine this happening every time a user visits your WordPress website. It puts a lot of load on your server and causes a slow loading time as fetching the requested data takes time, especially when there are many users making requests at the same time.</span></p>
<p><span style="font-weight: 400;">However, when you have a static version of your posts, the user is instantly served the page without making any requests to your server. This makes the content-serving process a lot faster, which paves the way for an overall much better loading time for your WordPress website.</span></p>
<p><span style="font-weight: 400;">This process might have been a bit difficult to implement with other CMS, but thanks to the huge plugin functionality in WordPress all you need to do is install and active a caching plugin to implement this.</span></p>
<p><span style="font-weight: 400;">We recommend the </span><a href="https://templatic.com/wp/recommend/w3-total-cache-2/"><span style="font-weight: 400;">W3 Total Cache</span></a><span style="font-weight: 400;"> plugin. You can install and activate it the same way we explained for the Yoast SEO plugin above.</span></p>
<p><span style="font-weight: 400;">Once activated, click on the General Settings under the W3 Performance options. For beginners, only Enable the Page Cache feature, which helps reduce the response time of your website.</span></p>
<p><span style="font-weight: 400;">If you understand technical stuff well, you can also consider enabling the Minify feature. However, you need to be sure it won’t affect the overall functioning of your website.</span></p>
<p><img   alt="" width="1590" height="847" data-srcset="https://templatic.com/wp-themes/uploads/2020/06/W3-Total-Cache-settings.png 1590w, https://templatic.com/wp-themes/uploads/2020/06/W3-Total-Cache-settings-768x409.png 768w, https://templatic.com/wp-themes/uploads/2020/06/W3-Total-Cache-settings-1536x818.png 1536w" sizes="(max-width: 1590px) 100vw, 1590px" data-src="https://templatic.com/wp-themes/uploads/2020/06/W3-Total-Cache-settings.png" class="alignnone size-full wp-image-48234 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="alignnone size-full wp-image-48234" src="https://templatic.com/wp-themes/uploads/2020/06/W3-Total-Cache-settings.png" alt="" width="1590" height="847" srcset="https://templatic.com/wp-themes/uploads/2020/06/W3-Total-Cache-settings.png 1590w, https://templatic.com/wp-themes/uploads/2020/06/W3-Total-Cache-settings-768x409.png 768w, https://templatic.com/wp-themes/uploads/2020/06/W3-Total-Cache-settings-1536x818.png 1536w" sizes="(max-width: 1590px) 100vw, 1590px" /></noscript></p>
<h3><b><i>Compressing Images</i></b></h3>
<p><span style="font-weight: 400;">Images are one of the biggest culprits leading to a slow loading website. This is especially true for </span><a href="https://templatic.com/wp/blogging-for-beginners/"><span style="font-weight: 400;">blogging websites</span></a><span style="font-weight: 400;"> or blog posts, which can have many high-quality images.</span></p>
<p><span style="font-weight: 400;">These image files are typically pretty large and increase the loading time of your site. So when it comes to speed optimization of your WordPress website, compressing images turns out to be an important factor too.</span></p>
<p><span style="font-weight: 400;">Again, it’s a big help to use WordPress as you can implement this otherwise complicated process with a few simple clicks.</span></p>
<p><span style="font-weight: 400;">You need to use a plugin to achieve this task as well. Simply install and activate the </span><a href="https://templatic.com/wp/recommend/wp-smushit/"><span style="font-weight: 400;">Smush Image Compression and Optimization</span></a><span style="font-weight: 400;"> plugin.</span></p>
<p><span style="font-weight: 400;">As soon as you activate this plugin, all the images you upload will be automatically compressed to load faster. As for the images you may have already uploaded, you can compress them in a batch of 50 images at a time.</span></p>
<p><img   alt="" width="1573" height="429" data-srcset="https://templatic.com/wp-themes/uploads/2020/06/Smush-image-compression-plugin.png 1573w, https://templatic.com/wp-themes/uploads/2020/06/Smush-image-compression-plugin-768x209.png 768w, https://templatic.com/wp-themes/uploads/2020/06/Smush-image-compression-plugin-1536x419.png 1536w" sizes="(max-width: 1573px) 100vw, 1573px" data-src="https://templatic.com/wp-themes/uploads/2020/06/Smush-image-compression-plugin.png" class="alignnone size-full wp-image-48235 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="alignnone size-full wp-image-48235" src="https://templatic.com/wp-themes/uploads/2020/06/Smush-image-compression-plugin.png" alt="" width="1573" height="429" srcset="https://templatic.com/wp-themes/uploads/2020/06/Smush-image-compression-plugin.png 1573w, https://templatic.com/wp-themes/uploads/2020/06/Smush-image-compression-plugin-768x209.png 768w, https://templatic.com/wp-themes/uploads/2020/06/Smush-image-compression-plugin-1536x419.png 1536w" sizes="(max-width: 1573px) 100vw, 1573px" /></noscript></p>
<p><span style="font-weight: 400;">There are also other things that help ensure a faster-loading WordPress website, but the ones we discussed above are the most important factors. Let us quickly take a look at some of the other things as well that can help reduce the loading time of your WordPress website.</span></p>
<ul>
<li style="font-weight: 400;"><span style="font-weight: 400;">Do not install too many plugins on your website</span></li>
<li style="font-weight: 400;"><span style="font-weight: 400;">Avoid installing outdated plugins</span></li>
<li style="font-weight: 400;"><span style="font-weight: 400;">Keep updating your plugins to their latest version as soon as possible</span></li>
<li style="font-weight: 400;"><span style="font-weight: 400;">Split the number of comments that appear on one page in the settings if your posts get too many comments</span></li>
<li style="font-weight: 400;"><span style="font-weight: 400;">Use platforms like YouTube instead of uploading video files directly to your website</span></li>
<li style="font-weight: 400;"><span style="font-weight: 400;">Avoid having too many ads on your website – ads can have a surprisingly significant impact on your website’s loading time</span></li>
</ul>
<p><a name="images"></a></p>
<h2><b>WordPress Image SEO</b></h2>
<p><span style="font-weight: 400;">While optimizing the images you post with your text content won’t guarantee page 1 rankings for your posts, it will definitely make an important contribution. Moreover, optimized images are very important for ranking in Google Images, so if you’re in a niche like food or fashion – where Google Images can drive a lot of traffic to your posts via images – you would absolutely want to work on optimizing your images.</span></p>
<p><span style="font-weight: 400;">And <a href="https://templatic.com/wp/best-image-optimizer-wordpress/">optimizing your images</a> isn’t all that difficult. There are a few simple things you need to do.</span></p>
<ul>
<li style="font-weight: 400;"><span style="font-weight: 400;">Rename your images to something relevant to the topic of your post instead of a random “image7622” file name when they are stored on your computer</span></li>
<li style="font-weight: 400;"><span style="font-weight: 400;">After uploading the images into your WordPress dashboard, put a short, SEO-rich title for them</span></li>
<li style="font-weight: 400;"><span style="font-weight: 400;">Write an alt text that gives a small introduction for the image</span></li>
<li style="font-weight: 400;"><span style="font-weight: 400;">This would be followed by a short description in the description section</span></li>
</ul>
<p><img   alt="" width="1540" height="684" data-srcset="https://templatic.com/wp-themes/uploads/2020/06/WordPress-image-optimization-for-SEO.png 1540w, https://templatic.com/wp-themes/uploads/2020/06/WordPress-image-optimization-for-SEO-768x341.png 768w, https://templatic.com/wp-themes/uploads/2020/06/WordPress-image-optimization-for-SEO-1536x682.png 1536w" sizes="(max-width: 1540px) 100vw, 1540px" data-src="https://templatic.com/wp-themes/uploads/2020/06/WordPress-image-optimization-for-SEO.png" class="alignnone size-full wp-image-48236 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="alignnone size-full wp-image-48236" src="https://templatic.com/wp-themes/uploads/2020/06/WordPress-image-optimization-for-SEO.png" alt="" width="1540" height="684" srcset="https://templatic.com/wp-themes/uploads/2020/06/WordPress-image-optimization-for-SEO.png 1540w, https://templatic.com/wp-themes/uploads/2020/06/WordPress-image-optimization-for-SEO-768x341.png 768w, https://templatic.com/wp-themes/uploads/2020/06/WordPress-image-optimization-for-SEO-1536x682.png 1536w" sizes="(max-width: 1540px) 100vw, 1540px" /></noscript></p>
<p><span style="font-weight: 400;">Here’s how you should go about optimizing your images.</span></p>
<p><span style="font-weight: 400;">However, there’s more to optimizing images. And the other part is optimizing them to load faster. But this is something we will cover under WordPress speed optimization below.</span></p>
<h4><b>Summing It Up</b></h4>
<p><span style="font-weight: 400;">SEO can make or break any online business. It’s arguably the best way to get targeted traffic to your website that convert into your customers or subscribers.</span></p>
<p><span style="font-weight: 400;">The steps and processes we have explained in this guide would help you build a solid SEO foundation and prepare your website to rank well for important keywords you would want to target.</span></p>
<p><span style="font-weight: 400;">However, you must not forget that off-page SEO – or backlinks – are going to be a very important factor too as far as actually ranking for your targeted keywords is concerned.</span></p>
<p><span style="font-weight: 400;">But if you’re posting well-written, useful content for your readers and implement everything we explained in this post well, your website may naturally attract quality backlinks over time, which would help rank it for your targeted keywords.</span></p>
    </div><!-- .entry-summary -->
            <div class="entry-meta">
	   
        </div><!-- .entry-meta -->
    	<div class="publisher-img">
    <div >
      <meta  content="https://templatic.com/wp-content/themes/templatic/images/logo.png">
      <meta  content="142">
      <meta  content="36">
    </div>
    <meta  content="Templatic - Premium WordPress Themes">
    </div>
	<meta  content="2020-06-25T20:32:47+05:30"/>
</article><!-- #post-## -->
                     	<div class="share-post">
            	<span>Share This Post:</span>
            	<ul>
                	<li><a class="facebook" href="https://www.facebook.com/sharer.php?u=https://templatic.com/newsblog/wordpress-seo/" target="_blank"><i aria-hidden="true" class="fa fa-facebook"></i> Facebook</a></li>
                    <li><a class="twitter" href="https://twitter.com/share?url=https://templatic.com/newsblog/wordpress-seo/" target="_blank"><i aria-hidden="true" class="fa fa-twitter"></i> Twitter</a></li>
                    <li><a class="googleplus" href="https://plus.google.com/share?url=https://templatic.com/newsblog/wordpress-seo/" target="_blank"><i aria-hidden="true" class="fa fa-google-plus"></i> Google+</a></li>
                    <li><a class="mail" href="/cdn-cgi/l/email-protection#0d325e786f67686e79305e64607d61682d5e656c7f682d4f78797962637e2b6c607d364f6269743044283f3d7e6c7a283f3d7965647e283f3d6c6369283f3d796562786a6579283f3d626b283f3d7462782c283f3d2d6579797d7e3722227968607d616c79646e236e62602263687a7e6f61626a227a627f697d7f687e7e207e686222"><i aria-hidden="true" class="fa fa-envelope"></i> Mail</a></li>
                </ul>
            </div>
            

           <!-- <div class="new-theme-banner">
                <a href="https://templatic.com/ecommerce-themes/storebox/"><img  alt="" data-src="https://templatic.com/wp-content/themes/templatic/images/storebox-post-banner.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://templatic.com/wp-content/themes/templatic/images/storebox-post-banner.jpg" alt="" /></noscript></a>
            </div> -->
			 
            <div class="widget subscribe-news widget-subscribe-news" id="tmpl_subscriber_widget2-2">
            <div class="widget-wrap widget-inside">
                <div id="mc_embed_signup">
            
                <!--form action="//templatic.us3.list-manage.com/subscribe/post?u=fb24487b2979713eeb3163461&amp;id=edd7a0c443" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate-->
				<form action="//templatic.us16.list-manage.com/subscribe/post?u=c20cba7f39214fb95a75c2344&amp;id=1f3261aff5" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
                    <div id="mc_embed_signup_scroll">
            
                    <h3 class="widget-title">Subscribe to Newsletter</h3>
                    <p>Signup to get a free ebook and regular updates and freebies from templatic.</p>
                    
                    <div class="mfg-wrap">
                        <div class="mc-field-group">
                            <label for="mce-FNAME">Name </label>
                            <input type="text" value="" name="FNAME" class="" id="mce-FNAME">
                        </div>
                        <div class="mc-field-group">
                            <label for="mce-EMAIL">Email <span class="asterisk">*</span></label>
                            <input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL">
                        </div>
                        <div class="mc-field-btn"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="btn btn-default btn-lg"></div>
            		</div>
                    <div id="mce-responses" class="clear">
            
                        <div class="response" id="mce-error-response" style="display:none"></div>
            
                        <div class="response" id="mce-success-response" style="display:none"></div>
            
                    </div>
                    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
            
                    <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_fb24487b2979713eeb3163461_edd7a0c443" tabindex="-1" value=""></div>
            
                    </div>
            
                </form>
            
                </div>
            </div>

            </div>
          
            <div class="sp-related-posts">
			<div id="related_posts"><h4>Related Posts</h4><ul>                <li>
                    <a href="https://templatic.com/newsblog/livemagazine-blog-theme-now-available-for-free-download/" rel="bookmark" title="LiveMagazine  Blog Theme &#8211; Now Available For Free Download">LiveMagazine  Blog Theme &#8211; Now Available For Free Download</a> 
                </li>
                                <li>
                    <a href="https://templatic.com/newsblog/authority-marketer-theme-launch/" rel="bookmark" title="Re-Introducing The Free Authority Marketer Theme">Re-Introducing The Free Authority Marketer Theme</a> 
                </li>
                                <li>
                    <a href="https://templatic.com/newsblog/best-wordpress-directory-themes/" rel="bookmark" title="Best WordPress Directory Themes to Build an Awesome Directory Site">Best WordPress Directory Themes to Build an Awesome Directory Site</a> 
                </li>
                                <li>
                    <a href="https://templatic.com/newsblog/pros-cons-wordpress-theme-club/" rel="bookmark" title="What Are Pros &#038; Cons of Buying a WordPress Theme Club?">What Are Pros &#038; Cons of Buying a WordPress Theme Club?</a> 
                </li>
                                <li>
                    <a href="https://templatic.com/support/support-policy/" rel="bookmark" title="Support Policy">Support Policy</a> 
                </li>
                                <li>
                    <a href="https://templatic.com/support/faq/" rel="bookmark" title="FAQ">FAQ</a> 
                </li>
                                <li>
                    <a href="https://templatic.com/newsblog/before-buying-any-directory-theme/" rel="bookmark" title="Before buying any directory theme…">Before buying any directory theme…</a> 
                </li>
                                <li>
                    <a href="https://templatic.com/newsblog/how-to-enable-wordpress-3-0-multisite/" rel="bookmark" title="How to Enable WordPress 3.0 Multisite">How to Enable WordPress 3.0 Multisite</a> 
                </li>
                                <li>
                    <a href="https://templatic.com/newsblog/furniture-woocommerce-theme/" rel="bookmark" title="Start selling products online now with the Elegant Furniture WooCommerce theme">Start selling products online now with the Elegant Furniture WooCommerce theme</a> 
                </li>
                                <li>
                    <a href="https://templatic.com/newsblog/free-custom-post-template-wordpress-plugin-released/" rel="bookmark" title="Free Custom Post Template WordPress plugin is released">Free Custom Post Template WordPress plugin is released</a> 
                </li>
                                <li>
                    <a href="https://templatic.com/newsblog/music-theme-bands-artists-musicians/" rel="bookmark" title="The Music Theme &#8211; Best WordPress theme for Music Bands">The Music Theme &#8211; Best WordPress theme for Music Bands</a> 
                </li>
                                <li>
                    <a href="https://templatic.com/newsblog/free-wordpress-post-badges-plugin-released/" rel="bookmark" title="Show &#8220;new&#8221; tag beside your WordPress post title using this free plugin">Show &#8220;new&#8221; tag beside your WordPress post title using this free plugin</a> 
                </li>
                                <li>
                    <a href="https://templatic.com/newsblog/free-wordpress-category-icon-plugin-released/" rel="bookmark" title="Free WordPress Category Icon plugin is released">Free WordPress Category Icon plugin is released</a> 
                </li>
                                <li>
                    <a href="https://templatic.com/newsblog/free-google-amp-wordpress-plugin-supporting-pages-taxonomy-posts-released/" rel="bookmark" title="Free Google AMP WordPress plugin supporting pages and taxonomy posts is released">Free Google AMP WordPress plugin supporting pages and taxonomy posts is released</a> 
                </li>
                                <li>
                    <a href="https://templatic.com/case-studies/wushu-sports-video-site/" rel="bookmark" title="Video Site that Introduces Wushu Sports to the World">Video Site that Introduces Wushu Sports to the World</a> 
                </li>
                </ul></div>            </div>
            
                                </section>
                        <div class="sidebar">
            <style>
/*.single .sidebar { margin-top:635px; }*/

.tnsb-list li {
	position: relative;
	padding-left: 20px;
}
.tnsb-list li:before {
	position: absolute;
	top: 0;
	left: 0;
	content: "";
	width: 5px;
	height: 5px;
	background-color: #3c48d5;
}
</style>


	
<div class="widget blue-host-ad">
	<a rel="nofollow" href="https://bit.ly/2Qp0ctK"><img style="max-width: 100%;"  alt="blue-host-ad" data-src="https://templatic.com/wp-themes/uploads/2020/03/bluehost-ad-banner-v1.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img style="max-width: 100%;" src="https://templatic.com/wp-themes/uploads/2020/03/bluehost-ad-banner-v1.jpg" alt="blue-host-ad" /></noscript></a>
</div>

<div class="widget wp-search">
	<h3 class="widget-title">Search</h3>
    <form class="searchform" role="search" method="get" id="searchform" action="https://templatic.com/">
        <div class="form-wrap">
            <input type="text" value="" name="s" id="s" placeholder="Search this site" />
            <input type="submit" id="searchsubmit" value="Search" />
        </div>
	</form>
</div>

<div class="widget top-themes">
	<h3 class="widget-title">Top Themes</h3>
	<ul class="tnsb-list">
		<li><a href="https://templatic.com/wordpress-directory-themes/directory/">Directory</a></li>
		<li><a href="https://templatic.com/wordpress-event-themes/eventum/">Eventum</a></li>
		<li><a href="https://templatic.com/wordpress-video-themes/video/">Video</a></li>
		<li><a href="https://templatic.com/wordpress-classifieds-themes/classifieds/">Classifieds</a></li>
		<li><a href="https://templatic.com/wordpress-directory-themes/spotfinder/">SpotFinder</a></li>
	</ul>
</div>

<div class="widget subscribe-news widget-subscribe-news" id="tmpl_subscriber_widget2-2">
<div class="widget-wrap widget-inside">
	<div id="mc_embed_signup">

	<!--form action="//templatic.us3.list-manage.com/subscribe/post?u=fb24487b2979713eeb3163461&amp;id=edd7a0c443" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate-->
	<form action="//templatic.us16.list-manage.com/subscribe/post?u=c20cba7f39214fb95a75c2344&amp;id=1f3261aff5" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
		<div id="mc_embed_signup_scroll">

		<h3 class="widget-title">Subscribe to Newsletter</h3>
		<p>Signup to get a free ebook and regular updates and freebies from templatic.</p>

		<div class="mc-field-group">

			<label for="mce-FNAME">Your Name </label>

			<input type="text" value="" name="FNAME" class="" id="mce-FNAME">

		</div>

		<div class="mc-field-group">

			<label for="mce-EMAIL">Your Email <span class="asterisk">*</span></label>

			<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL">

		</div>

		<div id="mce-responses" class="clear">

			<div class="response" id="mce-error-response" style="display:none"></div>

			<div class="response" id="mce-success-response" style="display:none"></div>

		</div>
		<!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->

		<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_fb24487b2979713eeb3163461_edd7a0c443" tabindex="-1" value=""></div>

		<div class="clear"><input type="submit" value="Subscribe Me" name="subscribe" id="mc-embedded-subscribe" class="btn btn-default btn-lg"></div>

		</div>

	</form>

	</div>
</div>
</div>


<div class="widget rec-tools">
	<h3 class="widget-title">Recommended Tools</h3>
	<ul class="tnsb-list">
		<li><a href="https://templatic.com/wp/blogvault-backup-migrations/" target="_blank">Backups - BlogVault</a></li>
		<li><a href="https://templatic.com/wp/malcare-wordpress-malware-removal-plugin/" target="_blank">Security - MalCare</a></li>
		<li><a href="https://templatic.com/wp/weglot-review/" target="_blank">Translations - Weglot</a></li>
		<li><a href="https://templatic.com/wp/elementor-review/" target="_blank">Page Builder - Elementor</a></li>
	</ul>
</div>

<!--<div class="widget latest-themes">
	<h3 class="widget-title">Become an Affiliate</h3>
	<figure><a rel="bookmark" href="//templatic.com/affiliates/" class="theme-img"><img alt=" theme"  itemprop="image" data-src="//templatic.com/wp-content/themes/templatic/images/templatic-affiliate-program.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="><noscript><img alt=" theme" src="//templatic.com/wp-content/themes/templatic/images/templatic-affiliate-program.jpg" itemprop="image"></noscript></a></figure>
</div>-->


<!--div class="widget ad-widget">
<a href="//templatic.com/wordpress-directory-themes/directory/"><img alt="Directory Theme for WordPress"  data-src="//templatic.com/wp-content/themes/templatic/images/homepage-directory.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="><noscript><img alt="Directory Theme for WordPress" src="//templatic.com/wp-content/themes/templatic/images/homepage-directory.jpg"></noscript></a>
</div>

<div class="widget latest-themes">
	<h3 class="widget-title">Special Offer</h3>
	<figure><a rel="bookmark" href="//templatic.com/directory-plugins-combo-offer/" class="theme-img"><img alt=" theme"  itemprop="image" data-src="//templatic.com/wp-content/themes/templatic/images/directory-plugin-combo-offer.png" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="><noscript><img alt=" theme" src="//templatic.com/wp-content/themes/templatic/images/directory-plugin-combo-offer.png" itemprop="image"></noscript></a></figure>
   
</div -->



<div id="tmpl_recent_post-2" class="widget latest-news widget-latest-news">
<div class="widget-wrap widget-inside">
	
	<h3 class="widget-title">Latest News</h3>
	<ul class="blog-news-list">
			<li>
		<span><strong>25</strong>Jun </span>
		<div class="blog_content">
			<a href="https://templatic.com/newsblog/wordpress-seo/">WordPress SEO: Everything You Need to Know About Optimizing Your WordPress Site for SEO</a>
		</div>
		<p><em class="pdate"><strong>25</strong> Jun</em></p>
		</li>
				<li>
		<span><strong>03</strong>Jun </span>
		<div class="blog_content">
			<a href="https://templatic.com/tips-tricks/creating-book-launch-website/">Creating a book launch website in 45 minutes, on your own</a>
		</div>
		<p><em class="pdate"><strong>03</strong> Jun</em></p>
		</li>
				<li>
		<span><strong>29</strong>May </span>
		<div class="blog_content">
			<a href="https://templatic.com/newsblog/authority-marketer-theme-launch/">Re-Introducing The Free Authority Marketer Theme</a>
		</div>
		<p><em class="pdate"><strong>29</strong> May</em></p>
		</li>
				<li>
		<span><strong>28</strong>May </span>
		<div class="blog_content">
			<a href="https://templatic.com/newsblog/livemagazine-blog-theme-now-available-for-free-download/">LiveMagazine  Blog Theme - Now Available For Free Download</a>
		</div>
		<p><em class="pdate"><strong>28</strong> May</em></p>
		</li>
				<li>
		<span><strong>20</strong>May </span>
		<div class="blog_content">
			<a href="https://templatic.com/newsblog/best-wordpress-directory-themes/">Best WordPress Directory Themes to Build an Awesome Directory Site</a>
		</div>
		<p><em class="pdate"><strong>20</strong> May</em></p>
		</li>
			</ul>

	<a class="read-more" href="//templatic.com/blog/"><strong>Read Rest of the News <i aria-hidden="true" class="fa fa-angle-right"></i></strong></a>


	<!-- listing_post_wrapper end-->
	</div>
</div>


<div class="widget blue-host-ad">
	<a rel="nofollow" href="https://bit.ly/2Qp0ctK"><img style="max-width: 100%;"  alt="blue-host-ad" data-src="https://templatic.com/wp-themes/uploads/2020/03/bluehost-ad-banner-v4.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img style="max-width: 100%;" src="https://templatic.com/wp-themes/uploads/2020/03/bluehost-ad-banner-v4.jpg" alt="blue-host-ad" /></noscript></a>
</div>

</aside>


<div class="widget wp-search">
	<h3 class="widget-title">Search</h3>
    <form class="searchform" role="search" method="get" id="searchform" action="https://templatic.com/">
        <div class="form-wrap">
            <input type="text" value="" name="s" id="s" placeholder="Search this site" />
            <input type="submit" id="searchsubmit" value="Search" />
        </div>
	</form>
</div>


<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
$win.on('load scroll', function() {
		if ( $('.post-single').length > 0 ) {
			var $contentHeight = $('.post-single').position().top + $('.post-single').height(),
				$currentPosition = $win.scrollTop()
			
			if ( ( ($contentHeight*0.25) <= $currentPosition ) && ( ($contentHeight*0.5) > $currentPosition ) ) {
				$('.widget-recommended-posts .post-1').css('opacity', '1')
			} else {
				if ( ( ($contentHeight*0.5) <= $currentPosition ) && ( ($contentHeight*0.75) > $currentPosition ) ) {
					$('.widget-recommended-posts .post-2').css('opacity', '1')
				} else {
					if ( ( ($contentHeight*0.75) <= $currentPosition ) && ( ($contentHeight) > $currentPosition ) ) {
						$('.widget-recommended-posts .post-3').css('opacity', '1')
					};
				};
			} 

			if ( ( 200 <= $currentPosition ) && ( ($contentHeight) > $currentPosition ) ) {
				$('.widget-share-links').stop(true, true).fadeIn(200);
				$('.widget-sidebar-cta').stop(true, true).fadeIn(200);
			} else {
				$('.widget-share-links').stop(true, true).fadeOut(200);
				$('.widget-sidebar-cta').stop(true, true).fadeOut(200);
			}

			if ( ( ($contentHeight*0.95) <= $currentPosition ) ) {
				$elWidth = $('.widget_trail').width();
				$winWidth = $win.width();
				$('.widget_trail').css({
					//'left': ($winWidth - $elWidth) + 'px' ,
					'left': '0px' ,
				});
			} 
		};

		if ( $('.sidebar .side-sticky').length > 0 ) {
			var widgetTrailPosition = $('.sidebar .side-sticky').offset().top
			var sidebarPosition = $('.sidebar').offset().top + $('.sidebar').outerHeight() - $('.sidebar .side-sticky').outerHeight()
			var foooterPosition = $('.site-content').offset().top - $('.sidebar .side-sticky').outerHeight()
			var winScroll = $win.scrollTop()

			if ( winScroll >= widgetTrailPosition ) {
				
				$('.sidebar .side-sticky').css('left', $('.site-content > .sidebar').offset().left)
				$('.sidebar .side-sticky').addClass('fixed')
				if ( sidebarPosition >= winScroll ) {
				$('.sidebar .side-sticky').css('left', 'auto')
					$('.sidebar .side-sticky').removeClass('fixed')
				};
			};

			if ( winScroll >= foooterPosition ) {
				$('.sidebar .side-sticky').css('left', '100%')

			} else {
				$('.sidebar .side-sticky').css('left', $('.site-content > .sidebar').offset().left)
				
			};
		} 
</script>
        </div>    
	</div>
	<!--Mailchimp Popup -->

<script type="text/javascript" src="//s3.amazonaws.com/downloads.mailchimp.com/js/signup-forms/popup/embed.js" data-dojo-config="usePlainJson: true, isDebug: false"></script>

<script type="text/javascript" src="//downloads.mailchimp.com/js/signup-forms/popup/embed.js" data-dojo-config="usePlainJson: true, isDebug: false"></script><script type="text/javascript">require(["mojo/signup-forms/Loader"], function(L) { L.start({"baseUrl":"mc.us16.list-manage.com","uuid":"c20cba7f39214fb95a75c2344","lid":"1f3261aff5"}) })</script>
<!-- /Mailchimp Popup -->
</div>

<footer class="footer">
    <!-- Hello bar starts > -->
    <div id="hellobar" class="hellobar msg1 show">
        Use Coupon <strong>JULY4</strong> for a <strong>45%</strong> Discount!
    </div>
	
    <div class="footer-top">
        <div class="container">
            <div class="widget wp-search">
                <form class="searchform" role="search" method="get" id="searchform" action="https://templatic.com">
                    <div class="form-wrap">
                        <input type="text" value="" name="s" id="s" placeholder="Search this site" />
                        <input type="submit" id="searchsubmit" value="Search" />
                    </div>
                </form>
            </div>

            <div class="soc-net">
                <span>Follow Us</span>
                <ul class="social-network">
                    <li class="cbp-so-side cbp-so-side-right">
                        <a href="//www.facebook.com/templatic" rel="nofollow"><img  alt="Facebook" data-src="https://templatic.com/wp-content/themes/templatic/images/facebook-icon.png" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://templatic.com/wp-content/themes/templatic/images/facebook-icon.png" alt="Facebook" /></noscript></a>
                    </li>
                    <li class="cbp-so-side cbp-so-side-right">
                        <a href="//twitter.com/templatic" rel="nofollow"><img  alt="Twitter" data-src="https://templatic.com/wp-content/themes/templatic/images/twitter-icon.png" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://templatic.com/wp-content/themes/templatic/images/twitter-icon.png" alt="Twitter" /></noscript></a>
                    </li>
                    <li class="cbp-so-side cbp-so-side-right">
                        <a href="//feeds.feedburner.com/templatic" rel="nofollow"><img  alt="RSS" data-src="https://templatic.com/wp-content/themes/templatic/images/rss-icon.png" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://templatic.com/wp-content/themes/templatic/images/rss-icon.png" alt="RSS" /></noscript></a>
                    </li>
                </ul>
            </div>
        </div>
    </div>

    <div class="footer-mid">
        <div class="container">
            <div class="ft-cols">
                <p class="ft-cols-head">Templatic</p>
                <ul>
                    <li><a href="https://templatic.com/about/">About</a></li>
                    <li><a href="https://templatic.com/blog/" >News Blog</a></li>
                    <li><a href="https://templatic.com/wp/">Slash WP Blog</a></li>
                    <li><a href="https://templatic.com/partners/">Partners</a></li>
                </ul>
            </div>
            <div class="ft-cols">
                <p class="ft-cols-head">Products</p>
                <ul>
                    <li><a href="https://templatic.com/wordpress-themes/">WordPress Themes</a></li>
                    <li><a href="https://templatic.com/wordpress-plugins/">WordPress Plugins</a></li>
                    <li ><a href="https://templatic.com/premium-themes-club/">Premium Themes Club</a></li>
                </ul>
            </div>
            <div class="ft-cols mv-hide">
                <p class="ft-cols-head">Support</p>
                <ul>
                    <li><a href="https://templatic.com/docs/" rel="nofollow">Documentation</a></li>
                    <li><a href="https://templatic.com/contact/" rel="nofollow">Contact</a></li>
                    <li><a href="https://templatic.com/showcase/">Showcase </a></li>
                </ul>
            </div>

            <div class="ft-cols mv-hide">
                <p class="ft-cols-head">Other</p>
                <ul>
                    <li class="mob-opt"><a href="https://templatic.com/affiliates/"  rel="nofollow">Become an Affiliate</a></li>
                    <li><a href="https://templatic.com/templatic-reviews/">Templatic Reviews</a></li>
                    <li><a href="https://templatic.com/careers/">Career - We are hiring</a></li>
                </ul>
            </div>

            <div class="ft-cols">
                <p class="ft-cols-head">Special</p>
                <ul>
                    <li><a href="https://templatic.com/wp/blogging-for-beginners/">Blogging for Beginners</a></li>
                    <li><a href="https://templatic.com/wordpress-directory-themes/directory/">Directory theme</a></li>
                    <li><a href="https://templatic.com/free-premium-theme-plugin-offer/?=footerlink">Any Theme or Plugin for FREE</a></li>
                </ul>
            </div>
        </div>
    </div>

    <div class="container footer-btm mv-hide">
        <p>&copy; 2008 - 2020 Templatic. All rights reserved. <br/>Proudly made by the Templatic Team
        </p>

        <ul>
            <li><a href="https://templatic.com/terms-of-use/" rel="nofollow">Terms &amp; Conditions</a></li>
            <li><a href="https://templatic.com/privacy-policy/" rel="nofollow">Privacy Policy</a></li>
            <li><a href="https://templatic.com/gdpr-policy/" rel="nofollow">GDPR Policy</a></li>
        </ul>
        <!--span> <a href="https://templatic.com/best-web-hosting-for-small-business/">Best web hosting for WordPress</a> by <a href="//templatic.com/bluehost" rel="nofollow">bluehost</a>.</span-->
    </div>
</footer>

<script type='text/javascript' src='https://templatic.com/wp-content/plugins/wp-smush-pro/app/assets/js/smush-lazy-load.min.js'></script>
<script type='text/javascript' src='https://templatic.com/wp-includes/js/wp-embed.min.js'></script>
<script>
jQuery('.togal-price-div').on('click', function(){
	var parent_id = jQuery(this).parent().parent().attr('class');
	jQuery(this).parent().parent().find('.pack_content').slideToggle( "slow" );
    jQuery('.togal-price-div').toggleClass("show-pkg");
});
</script>
<!-- Mailchimp Popup-->
<!--<script type="text/javascript" src="//downloads.mailchimp.com/js/signup-forms/popup/unique-methods/embed.js" data-dojo-config="usePlainJson: true, isDebug: false"></script>
<script>
    function showMailingPopUp() {
    window.dojoRequire(["mojo/signup-forms/Loader"], function(L) { L.start({"baseUrl":"mc.us16.list-manage.com","uuid":"c20cba7f39214fb95a75c2344","lid":"1f3261aff5","uniqueMethods":true}) })
     document.cookie = 'MCPopupClosed=;path=/;expires=Thu, 01 Jan 1970 00:00:00 UTC;';
     document.cookie = "MCPopupSubscribed=; path=/; expires=Thu, 01 Jan 1970 00:00:00 UTC";
    }
    document.getElementById("mailchimp_10p").onclick = function() {showMailingPopUp()};
    document.getElementById("mailchimp_10pc").onclick = function() {showMailingPopUp()};
</script>-->
</body>
</html>
